大智慧实用CCI指标公式,大智慧觉得很好的指标公式

股票公式 | 发布于2021-09-15

大智慧实用CCI指标公式

TYP := (HIGH + LOW + CLOSE)/3;

CCI14:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14));

CCI24:(TYP-MA(TYP,24))/(0.015*AVEDEV(TYP,24)),LINETHICK2,COLORgreen;

CCI84:(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84)),LINETHICK1,COLORSTICK;

CCI084:(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84)),LINETHICK3,COLORYELLOW;

CCI168:(TYP-MA(TYP,168))/(0.015*AVEDEV(TYP,168)),LINETHICK4,COLORblue;

CCI840:(TYP-MA(TYP,840))/(0.015*AVEDEV(TYP,840)),LINETHICK4,COLORred;

底背离14:LLV(L,55)=L AND NOT(LLV(CCI14,55)=CCI14);

底背离84:LLV(L,55)=L AND NOT(LLV(CCI84,55)=CCI84);

顶背离14:hhv(h,55)=h AND NOT(hhv(CCI14,55)=CCI14);

顶背离84:hhv(h,55)=h AND NOT(hhv(CCI84,55)=CCI84);

DRAWTEXT(底背离14>0,150,'底' ),COLORyellow;

DRAWTEXT(底背离14>0,50,'背' ),COLORyellow;

DRAWTEXT(底背离14>0,0,'离' ),COLORyellow;

DRAWTEXT(底背离84>0,100,'底' ),COLORgreen;

DRAWTEXT(底背离84>0,50,'背' ),COLORgreen;

DRAWTEXT(底背离84>0,0,'离' ),COLORgreen;

DRAWTEXT(顶背离14>0,150,'顶' ),COLORRED,linethick2;

DRAWTEXT(顶背离14>0,50,'背' ),COLORRED;

DRAWTEXT(顶背离14>0,0,'离' ),COLORRED;

DRAWTEXT(顶背离84>0,200,'顶' ),COLORwhite,linethick2;

DRAWTEXT(顶背离84>0,50,'背' ),COLORBLUE;

DRAWTEXT(顶背离84>0,0,'离' ),COLORBLUE;

DIFF := EMA(CLOSE,7) - EMA(CLOSE,26);

DEA := EMA(DIFF,9);

顶背离m:=hhv(h,55)=h AND NOT(hhv(DIFF,55)=DIFF);

100,POINTDOT,COLORRED;

200,POINTDOT;

0;

-200,POINTDOT;

d:=CCI84<CCI168;

f:=count(d,12)>9 and CCI24>CCI84 and not(顶背离m) and cci14>cci24 ;

xg:c<ref(c,1) and cross(CCI14,CCI24);

DRAWICON(xg,0,5 );

xg波段:f and cross(CCI84,CCI168);

DRAWICON(xg波段,350,7);DRAWTEXT(xg波段,330,'抄' ),LINETHICK3,COLORYELLOW; 

DRAWTEXT(xg波段,300,'底' ),LINETHICK3,COLORYELLOW;

a:=ref(xg波段,1) and c<ref(c,1);

bbi:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;

woxg:count(a,10)>0 and cross(c,bbi);

 DRAWTEXT(woxg,300,'!' ),LINETHICK3,COLORYELLOW;

ZTJ:=cross(CCI168,CCI840) and CCI840>0;

主升浪:ZTJ AND (REF(BARSLAST(ZTJ),1)>20 OR BARSSINCE(ZTJ)=0);

 DRAWTEXT(主升浪,480,'主升浪' ),LINETHICK3,COLORmagenta;  

大智慧觉得很好的指标公式

散户:EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7),linethick3;;

ma5:ma(散户,3),colorblue,linethick3;

FILLRGN(散户,0, 散户>0,rgb(255,0,0), 散户<0 ,rgb(0,55,0) );

0;

FILLRGN(散户,ma5, 散户>0 and 散户<ma5,rgb(0,0,255), 散户<0 and 散户>ma5 and 散户<0,rgb(255,255,55) );

{主力:EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2),colorstick;

主力1:EMA( (CLOSE-MA(CLOSE,3))/MA(CLOSE,3),2);

散户:EMA( (CLOSE-MA(CLOSE,20))/MA(CLOSE,20),7),linethick3;;

ma5:ma(散户,4),colorblue,linethick3;

FILLRGN(散户,主力, 散户>主力,rgb(255,0,0), 散户<主力 and 主力<0,rgb(0,55,0) );

0;

FILLRGN(散户,ma5, 散户>主力 and 散户<ma5,rgb(0,0,255), 散户<主力 and 散户>ma5 and 散户<0,rgb(255,255,55) );

};

RSV:=(((CLOSE - LLV(LOW,36)) / (HHV(HIGH,36) - LLV(LOW,36))) * 100);

Y0:=SMA(RSV,7,1);

Y1:=SMA(SMA(RSV,7,1),3,1);

Y2:=(((CLOSE/COST(13))<=0.8)*10);

Y3:=SMA(Y0,7,1);

k:y0-y1,linethick0;

k1:y1-y3,linethick0;

k2:y0-y3,linethick0;

TYP := (HIGH + LOW + CLOSE)/3;

CCI14:(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK0;

CCI24:(TYP-MA(TYP,24))/(0.015*AVEDEV(TYP,24)),LINETHICK0;

CCI84:(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84)),LINETHICK0;

CCI084:(TYP-MA(TYP,84))/(0.015*AVEDEV(TYP,84)),LINETHICK0;

CCI168:(TYP-MA(TYP,168))/(0.015*AVEDEV(TYP,168)),LINETHICK0;

CCI840:(TYP-MA(TYP,840))/(0.015*AVEDEV(TYP,840)),LINETHICK0;

n:=13;

cor:=SUM(IF(CLOSE>REF(CLOSE,1),(VOL/capital)*(2*c-2*o-(h-c)+(o-l)),IF(CLOSE<REF(CLOSE,1),-(VOL/capital)*(2*o-2*c+(h-o)-(c-l)),0)),0);ROC:=(cor-REF(ma(Cor,21),n))/REF(ma(Cor,21),n)*100;

ROCMA9:=MA(ROC,8);

ROCMA3:=eMA(ROC,3);

短线:roc>rocma3 and rocma3>rocma9,LINETHICK0;

工作区:k>0 and k1>0 and k2>0 {and cci14>cci24 and cci24>cci84}, linethick0;STICKLINE(工作区,散户,0.2,1,0),COLORyellow;

STICKLINE(短线,散户+0.02,0.15,4,0),COLORwhite;

该文观点仅代表作者本人,贝壳投研系信息发布平台

贝壳投研从多维度分析,整理了一份《成长50》的名单,可以关注同名公众号:"贝壳投研":Beiketouyan,进行领取(点击复制)

/阅读下一篇/

大智慧牛气冲天主图指标公式,大智慧超级趋势指标公式

可能感兴趣的
热门推荐