大智慧七日均线主图指标公式,大智慧准买卖指标公式

股票公式 | 发布于2021-09-18

大智慧七日均线主图指标公式

b:="LTFunc6@FORLT2";

s11:="LTFunc6@LT_S1";

hs:="LTFunc6@LT_HS";

ls:="LTFunc6@LT_LS";

p1:="LTFunc6@LT_P1";

upp:="LTFunc6@LT_UPP";

udd:="LTFunc6@LT_UDD";

p1:="LTFunc6@LT_P1";

drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;

drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2;

MA7:EMA(CLOSE,7);

PARTLINE(MA7,MA7>REF(MA7,1),RGB(255,0,0),MA7<REF(MA7,1),RGB(0,120,0),1,RGB(0,0,255)),LINETHICK2;

MID:MA(CLOSE,20),COLORYELLOW;

UPPER:MID+2*STD(CLOSE,20),COLORRED,DOTLINE;

LOWER:MID-2*STD(CLOSE,20),COLORGREEN,DOTLINE;

流通盘大小:=FINANCE2(37)/1000000*100;

DRAWTEXTABS(20,20,'总股本:'+NUMTOSTR(FINANCE2(35)/10000 )+'亿'+' 流通股:'+ NUMTOSTR(CAPITAL/1000000)+'亿'),COLORACFFFF;

DRAWTEXTABS(20,35,'上市日期:'+STR(FINANCE2(2))+'日'),ColorACFFFF;

每股收益:=FINANCE2(3);

每股市盈率:=DYNAINFO(39);

每股净资产:=FINANCE2(4);

销售毛利率:=FINANCE2(12);

主营收入同比:=FINANCE2(11);

净利润同比增长:=FINANCE2(10);

每股公积金:=FINANCE2(7);

每股未分配:=FINANCE2(8);

{DRAWTEXTABS(20,40,'基本面优劣提示:'),COLOR505050;

}DRAWTEXTABS(20,50,'每股收益:'+NUMTOSTRN(每股收益,2)+'元'),COLORACFFFF;

DRAWTEXTABS(20,65,'每股市盈率:'+NUMTOSTRN(每股市盈率,1)+'倍'),COLORACFFFF;

DRAWTEXTABS(20,80,'每股净资产:'+NUMTOSTRN(每股净资产,2)+'元'),COLORACFFFF;

DRAWTEXTABS(20,95,'每股公积金:'+NUMTOSTRN(每股公积金,2)+'元'),ColorACFFFF;

DRAWTEXTABS(20,110,'每股未分配:'+NUMTOSTRN(每股未分配,2)+'元'),ColorACFFFF;

DRAWTEXTABS(20,125,'销售毛利率:'+NUMTOSTRN(销售毛利率,2)+'%'),COLORACFFFF;

DRAWTEXTABS(20,140,'主营收入同比增长:'+NUMTOSTRN(主营收入同比,2)+'%'),COLORACFFFF;

DRAWTEXTABS(20,155,'净利润同比增长:'+NUMTOSTRN(净利润同比增长,2)+'%'),COLORACFFFF;

{DRAWTEXTABS(20,80,'换手率高低提示:'),COLOR505050;

}DRAWTEXTABS(20,5,'所属板块:'+BKNAME),COLORACFFFF;

大智慧准买卖指标公式

RSV:= (CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;

K:= SMA(RSV,3,1);

D:= SMA(K,3,1);

J:= 3*K-2*D;

STICKLINE(K>D,D,K,6,0),COLORFF00FF;

STICKLINE(K<=D,D,K,6,0),COLORFF0000;

DRAWTEXT(K>D,0,'買'),COLOR0000FF;

DRAWTEXT(K<D,0,'賣'),COLORFF0000;

DRAWTEXT(D<REF(D,1),0,'賣'),COLORFF0000;

DRAWTEXT(J>=REF(J,1),0,'買'),COLOR0000FF;

N:= 2;

M:= 3;

VAR2:= 1;

VAR3:= REF(HIGH,1)*1.1;

VAR4:= HIGH*1.1;

VAR5:= (VAR4*VOL+VAR3*(CAPITAL-VOL))/CAPITAL;

VAR6:= REF(LOW,1)*0.9;

VAR7:= LOW*0.9;

VAR8:= (VAR7*VOL+VAR6*(CAPITAL-VOL))/CAPITAL;

VAR9:= EMA(VAR8,30);

VARA:= EMA(VAR5,30);

VARB:= VARA-2;

VARC:= IF(CLOSE<=VAR9,VARB,VARA);

VARD:= MA(CLOSE,80)-MA(CLOSE,10)/17;

STICKLINE(VARC-VARB=0 AND VAR2 AND CROSS((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,MA((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,M)),50,0,5,0),LINETHICK0,COLOR0000FF;

DRAWTEXT(FILTER(VARC-VARB=0 AND CROSS((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,MA((EMA(EMA(EMA(CLOSE,N),N),N)-REF(EMA(EMA(EMA(CLOSE,N),N),N),1))/REF(EMA(EMA(EMA(CLOSE,N),N),N),1)*100,M)),4),55,'买入'),COLOR00FFFF;

VARE:= (CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34))*100;

卖出线: SMA(SMA(VARE,3,1),3,1),LINETHICK0,COLORFF6633;

买入线: 3*SMA(VARE,3,1)-2*卖出线,LINETHICK0,COLOR0000FF;

DRAWICON(CROSS(90,买入线),90,2),COLOR00FFFF;

STICKLINE(CROSS(90,买入线),15,0,5,0),LINETHICK0,COLOR008000;

STICKLINE(SMA(VARE,3,1)>卖出线,SMA(VARE,3,1),卖出线,4,0),LINETHICK0,COLOR1133FF;

该文观点仅代表作者本人,飞鲸投研系信息发布平台

飞鲸投研从多维度分析,整理了一份《成长50》的名单,可以关注同名公众号:"飞鲸投研":Beiketouyan,进行领取(点击复制)

/阅读下一篇/

大智慧短期箱体主图指标公式,大智慧招招绝主图指标公式

可能感兴趣的
热门推荐