大智慧短期箱体主图指标公式,大智慧招招绝主图指标公式

股票公式 | 发布于2021-09-18

大智慧短期箱体主图指标公式

m2:MA(C,2),COLORRED,LINETHICK1;

m5:MA(C,5),PRECIS2,LINETHICK2;

m20:MA(C,20),PRECIS2,LINETHICK1;

m60:MA(C,60),PRECIS2,LINETHICK1;

AA:=CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>REF(CLOSE,2) AND REF(CLOSE,1)<REF(CLOSE,3) AND IF(REF(CLOSE,3)<REF(CLOSE,4),1,IF(REF(CLOSE,4)<REF(CLOSE,5),REF(CLOSE,1)<REF(CLOSE,4) OR (REF(CLOSE,2)<REF(CLOSE,4) AND REF(CLOSE,3)>=REF(CLOSE,5)),IF(REF(CLOSE,5)<REF(CLOSE,6),1,REF(CLOSE,6)<REF(CLOSE,7))));

DRAWTEXT(AA AND CLOSE>REF(OPEN,2),LOW*0.98,'↑'),COLORYELLOW;

BB:=CLOSE<REF(CLOSE,1) AND REF(CLOSE,1)<REF(CLOSE,2) AND REF(CLOSE,1)>REF(CLOSE,3) AND IF(REF(CLOSE,3)>REF(CLOSE,4),1,IF(REF(CLOSE,4)>REF(CLOSE,5),REF(CLOSE,1)>REF(CLOSE,4) OR (REF(CLOSE,2)>REF(CLOSE,4) AND REF(CLOSE,3)<=REF(CLOSE,5)),IF(REF(CLOSE,5)>REF(CLOSE,6),1,REF(CLOSE,6)>REF(CLOSE,7))));

DRAWTEXT(BB AND CLOSE<REF(CLOSE,2),HIGH*1.02,'↓'),COLOR00FF00;

MA18:=MA(CLOSE,18);

VAR1:=C=HHV(C,4) AND REF(C,1)=LLV(C,4);

VAR2:=C=LLV(C,4) AND (REF(C,1)<REF(C,2) OR REF(C,1)<REF(C,3)) OR REF(C,1)=LLV(C,4) AND C<REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)=HHV(C,4) AND C<REF(C,1) OR REF(C,3)=LLV(C,4) AND C<REF(C,1) AND C<REF(C,2);

VAR3:=REF(C,1)=LLV(C,4) AND C>=REF(C,2) OR REF(C,2)=LLV(C,4) AND REF(C,1)<=REF(C,3) AND REF(C,2)<REF(C,4) AND C>=REF(C,1);

A:=(3*C+L+O+H)/6;

VAR4:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+REF(A,20))/210;

MTM:=C-REF(C,1);

DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

CB:=EMA(VAR4,13);

STICKLINE(VAR3,O,(O+C)/2,3,0),COLOR00FFFF,LINETHICK7;

STICKLINE(VAR3,O,(O+C)/2,0.5,0),COLOR00FFFF,LINETHICK7;

NN:= DISPSTATUS=2;

A1:=REF(HIGH,3)=HHV(HIGH,2*3+1);

B1:=FILTER(A1,3);

C1:=BACKSET(B1,3+1);

D1:=FILTER(C1,3);

A2:=REF(LOW,3)=LLV(LOW,2*3+1);

B2:=FILTER(A2,3);

C2:=BACKSET(B2,3+1);

D2:=FILTER(C2,3);

E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;

E2:=(HIGH+LOW)/2;

H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS OR BARSCOUNT(CLOSE)=1;

L1:=(D2 AND NOT(D1 AND E1=E2));

X1:=REF(BARSLAST(H1),1)+1;

F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));

G1:=F1>REF(F1,1);

I1:=BACKSET(G1,2);

LD:=I1>REF(I1,1);

L2:=LD OR BARSTATUS OR BARSCOUNT(CLOSE)=1;

X2:=REF(BARSLAST(L2),1)+1;

F2:=BACKSET(L2 AND COUNT(H1,X2)>0,HHVBARS(IF(H1,HIGH,0),X2));

G2:=F2>REF(F2,1);

I2:=BACKSET(G2,2);

HD:=I2>REF(I2,1);

UU:=BACKSET(BARSTATUS,BARSLAST(LD)+1);

VV:=UU>REF(UU,1);

WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);

XX:=WW>REF(WW,1);

UU2:=BACKSET(BARSTATUS,BARSLAST(HD)+1);

VV2:=UU2>REF(UU2,1);

WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);

XX2:=WW2>REF(WW2,1);

上:REF(H,BARSLAST(XX2)),PRECIS2,Color0000FF,LINETHICK1;

压:REF(H,BARSLAST(VV2)),PRECIS2,Color0000FF,LINETHICK1,DOTLINE;

支:REF(L,BARSLAST(VV)),PRECIS2,COLORYELLOW,LINETHICK1,DOTLINE;

下:REF(L,BARSLAST(XX)),COLORYELLOW,PRECIS2,LINETHICK1;

DRAWTEXT(nn,支,'支: '+NUMTOSTRN(支,2)+'元'),ALIGN2,COLORYELLOW,VALIGN0,LINETHICK1;

DRAWTEXT(nn,压,'压: '+NUMTOSTRN(压,2)+'元'),ALIGN2,COLORYELLOW,VALIGN2,LINETHICK1;

DRAWTEXT(nn,下,'下: '+NUMTOSTRN(下,2)+'元'),ALIGN2,COLORYELLOW,LINETHICK1,VALIGN0;

DRAWTEXT(nn,上,'上: '+NUMTOSTRN(上,2)+'元'),ALIGN2,COLORYELLOW,LINETHICK1,VALIGN2;

DRAWTEXTREL(10,60,'所属板块:'+BKNAME),ColorAFFF00;

大智慧招招绝主图指标公式

A3 :(EMA(CLOSE,5)+MA(CLOSE,10)+MA(CLOSE,15))/3,colorff00ff;

a4 :(EMA(CLOSE,20)+MA(CLOSE,25)+MA(CLOSE,30))/3,color00ff00;

A5 :(EMA(CLOSE,40)+MA(CLOSE,50)+MA(CLOSE,60))/3,coloryellow;

a6 :(EMA(CLOSE,80)+MA(CLOSE,85)+MA(CLOSE,90))/3,colorff9900;

A7 :(EMA(CLOSE,120)+MA(CLOSE,130)+MA(CLOSE,150))/3,color0000ff;

a8 :(EMA(CLOSE,160)+MA(CLOSE,170)+MA(CLOSE,180))/3,coloryellow;

A9 :(EMA(CLOSE,200)+MA(CLOSE,225)+MA(CLOSE,250))/3,color00ff00;

V1:EMA(CLOSE,5),Color00FFFF;

V2:EMA((EMA(CLOSE,29))*(1.01),10),ColorFF00FF;

DRAWICON(CROSS(V1,V2),V2,1),Color00FF00;

V3:EMA(CLOSE,10),ColorFFFFFF;

V4:EMA((EMA(CLOSE,60))*(0.99),10),ColorFFFF00;

DRAWICON(CROSS(V3,V4),V2,1),Color0000FF;

VF1:=MA(CLOSE,60)-MA(CLOSE,5)/3.2;

DRAWTEXT(IF(CLOSE<VF1 ANDVOL/240>MA(VOL,5)/240 AND CLOSE>=REF(CLOSE,1)*1.08 AND CLOSE<MA(CLOSE,13)*1.3,1,0),LOW,'☆'),colorred;

VarA:=(CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;

VarB:=EMA(0.667*REF(VarA,1)+0.333*VarA,5);

DRAWTEXT(IF(VOL>=1.3*MA(VOL,5) AND COUNT(VarA>=VarB and VarA<-17,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'★注意买入');

Varr1:=SMA(MAX(CLOSE-ref(c,1),0),12,1)/SMA(ABS(CLOSE-ref(c,1)),15,1)*100;

DRAWICON(CROSS(82,Varr1),HIGH,2);

DRAWTEXT(CROSS(82,Varr1),high,'快卖↓'),coloryellow;

Var1:=(HIGH+LOW+OPEN+2*CLOSE)/5;

Var2:=REF(Var1,1);

Var3:=SMA(MAX(Var1-Var2,0),10,1)/SMA(ABS(Var1-Var2),10,1)*100;

HY3:=IF(COUNT(Var3<20,5)>=1 AND COUNT(Var1=LLV(Var1,10),10)>=1 AND CLOSE>=OPEN*1.038 AND VOL>MA(VOL,5)*1.2,1,0);

DRAWTEXT(hy3,low,'▲买入'),colorred;

Var1:=EMA(C,3);

Var2:=EMA(C,5);

Var3:=EMA(C,10);

Var4:=EMA(C,20);

Var5:=EMA(C,30);

Var6:=(Var2+Var3+Var4+Var5)/4;

Var7:=(Var6-REF(Var6,15))/REF(Var6,15)*100;

Var8:=(Var6-REF(Var6,15))/REF(Var6, 15)*100;

Var9:=EMA(Var7,8);

STICKLINE(Var7<1*REF(Var7,1),h,l,0.5,0),COLORBLUE;

{蓝-持币}STICKLINE(Var7<1*REF(Var7,1),o,c,5, 1),COLORBLUE;

STICKLINE(Var7>1*REF(Var7,1),h,l,0.5,0),COLORRED;

{红-持股}STICKLINE(Var7>1*REF(Var7,1),o,c,5, 1),COLORRED;

STICKLINE(Var7<1*REF(Var7,1) AND Var9>1*REF(Var9,1),h,l,0.5,0),COLORGREEN;

{绿-洗盘}STICKLINE(Var7<1*REF(Var7,1) AND Var9>1*REF(Var9,1),o,c,5, 1),COLORGREEN;

买进价:=((c-ref(ma(c,6),1))/6+ma(c,6))*1.004;

买进条件:=cross(c,买进价) and 买进价>ref(买进价,1);

STICKLINE(买进条件,h,l,0.5,1),colorwhite,linethick2;

{白-买进}STICKLINE(买进条件,o,c,6,0),colorwhite,linethick2;

加码价:=((c-ref(ma(c,18),1))/18+ma(c,18))*1.004;

加码条件:=cross(c,加码价) and 加码价>ref(加码价,1);

STICKLINE(加码条件,h,l,0.5,1),coloryellow,linethick2;

{黄-加码}STICKLINE(加码条件,o,c,6,0),coloryellow,linethick2;

X1:EMA(C,7),color0088ff;

X2:EMA(c,21),coloree00ee;

X3:EMA(X2,21),colorwhite;

x4:ema(x3,27),color009900;

x5:ema(x2,100),colorFFAA00;

x6:ema(x5,100),color009999;

Tags: 大智慧
该文观点仅代表作者本人,飞鲸投研系信息发布平台

飞鲸投研从多维度分析,整理了一份《成长50》的名单,可以关注同名公众号:"飞鲸投研":Beiketouyan,进行领取(点击复制)

/阅读下一篇/

大智慧看黑马主图指标公式,大智慧带筹码峰主图指标公式

可能感兴趣的
热门推荐