大智慧MACD新战法指标公式,大智慧坚决抄底指标公式

股票公式 | 发布于2021-09-15

大智慧MACD新战法指标公式

DIFF:=(EMA(CLOSE,12) - EMA(CLOSE,26));

DEA:=EMA(DIFF,9);

MACD2:=(2 * (DIFF - DEA));

DU0:=CROSS(DIFF,0);

UD0:=CROSS(0,DIFF);

TDU0:=BARSLAST(DU0);

TUD0:=BARSLAST(UD0);

DU3:=REF(DU0,1);

UD3:=REF(UD0,1);

TDU3:=BARSLAST(DU3);

TUD3:=BARSLAST(UD3);

UDGLINE:=IF((TDU3 < TUD3),REF(HHV(HIGH,2),TDU3),REF(LLV(LOW,2),TUD3));

JDU0:=(((REF(CLOSE,1) <= REF(UDGLINE,1)) AND (CLOSE > UDGLINE)) AND (TDU0 < TUD0));

JUD0:=(((REF(CLOSE,1) >= REF(UDGLINE,1)) AND (CLOSE < UDGLINE)) AND (TUD0 < TDU0));

JDU1:=(JDU0 AND (COUNT(JDU0,TDU0) = 1));

JUD1:=(JUD0 AND (COUNT(JUD0,TUD0) = 1));

JDU2:=(JDU1 AND (REF(BARSLAST(JUD1),1) < REF(BARSLAST(JDU1),1)));

JUD2:=(JUD1 AND (REF(BARSLAST(JUD1),1) > REF(BARSLAST(JDU1),1)));

JDU3:=(JDU1 AND (REF(BARSLAST(JUD1),1) > REF(BARSLAST(JDU1),1)));

JUD3:=(JUD1 AND (REF(BARSLAST(JUD1),1) < REF(BARSLAST(JDU1),1)));

BSLINE:=IF((BARSLAST(JDU2) < BARSLAST(JUD2)),IF(REF(CROSS(0,MACD2),1),LLV(LOW,2),REF(LLV(LOW,2),BARSLAST(REF(CROSS(0,MACD2),1)))),IF(REF(CROSS(MACD2,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD2,0),1)))));

DRAWICON((JDU1 OR (BARSLAST(JDU1) < BARSLAST(JUD1))),0,10);

STICKLINE((MACD2>=0),0,MACD2,3,1),COLOR0000FF;

STICKLINE(((MACD2>=0) AND (MACD2 < REF(MACD2,1))),0,MACD2,3,0),COLORCYAN;

STICKLINE((MACD2<0),0,MACD2,3,0),COLORFFFF00;

STICKLINE(((MACD2<0) AND (MACD2 > REF(MACD2,1))),0,MACD2,3,1),COLORRED;

DIF:DIFF,LINETHICK2,COLOR00FFFF;

DEF:DEA,COLOR00FF00;

MACD:MACD2,LINETHICK0,COLORFFFF00;

DEFUT:=BARSLAST(CROSS(MACD2,0));

DEFDT:=BARSLAST(CROSS(0,MACD2));

DEFUL:=IF((MACD2 >= 0),HHV(MACD2,(DEFUT + 1)),REF(HHV(MACD2,(DEFUT + 1)),(DEFDT + 1)));

DEFDL:=IF((MACD2 < 0),LLV(MACD2,(DEFDT + 1)),REF(LLV(MACD2,(DEFDT + 1)),(DEFUT + 1)));

DEFU2L:=REF(DEFUL,(DEFUT + 1));

DEFD2L:=REF(DEFDL,(DEFDT + 1));

DRAWICON(((((LLV(MACD2,4) > 0) AND (MACD2 < REF(MACD2,1))) AND (REF(MACD2,1) > REF(MACD2,2))) AND (REF(MACD2,2) > REF(MACD2,3))),MACD2,5);

DRAWICON(((((HHV(MACD2,4) < 0) AND (MACD2 > REF(MACD2,1))) AND (REF(MACD2,1) < REF(MACD2,2))) AND (REF(MACD2,2) < REF(MACD2,3))),MACD2,4);

DRAWICON(((((JUD1 OR (BARSLAST(JDU1) > BARSLAST(JUD1))) AND (MACD2 >= 0)) AND (REF(MACD2,1) < REF(DEFU2L,1))) AND (MACD2 > DEFU2L)),MACD2,12);

DRAWICON(((((JDU1 OR (BARSLAST(JDU1) < BARSLAST(JUD1))) AND (MACD2 < 0)) AND (REF(MACD2,1) > REF(DEFD2L,1))) AND (MACD2 < DEFD2L)),MACD2,12);  

大智慧坚决抄底指标公式

VAR3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;

VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;

VAR5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;

VAR6:=(VAR3+VAR4+VAR5)/3;

VAR7:=EMA(VAR6,5);

指标: EMA(EMA(VAR3,5),5)*3, COLORSTICK;

VAR8:=IF(VAR6<=-20,10,0);

VAR9:=HHV(VAR8,10);

STICKLINE(VAR8=10,20,10,5,0),COLOR6666FF;

VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);

K:EMA(VAR7,5)*2, COLORFF00FF;

D:EMA(K,5), COLORWHITE;

J:K*3-D*2, COLORYELLOW;

VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;

换手: VOL/CAPITAL*100,COLORGREEN;

DRAWTEXT(VARA=20,15,'底部'),LINETHICK1,COLORWHITE;

STICKLINE((VARA=20),0,10,5,0),COLORWHITE;

抄底:VARA=20;

VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;

VARF:=100-3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR10:=100-3*SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);

VAR11:=VARF<REF(VAR10,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

DRAWTEXT(VAR11 AND COUNT(VAR11,30)=1,15,'坚决抄底'),LINETHICK1,COLORFF00FF;

STICKLINE(VAR11 AND COUNT(VAR11,30)=1,1,10,5,0),COLORFF00FF;

VAR12:=(HIGH+LOW+CLOSE)/3;

VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));

VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));

VAR15:=IF(VAR13>=150 AND VAR13<200 AND VAR14>=150 AND VAR14<200,10,0);

VAR16:=IF(VAR13<=-150 AND VAR13>-200 AND VAR14<=-150 AND VAR14>-200,-10,VAR15);

VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;

VAR18:=100-ABS(VAR17);

VAR19:=IF(VAR18<90,VAR18,100);

VAR1A:=IF(VARE>0,VARE,0);

VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR14<=-200 AND VAR13<=-150,-15,VAR16))+60;

VAR1C:=VAR1A>48 AND VAR1B>60 AND VAR19<100;

DRAWTEXT(VAR1C AND COUNT(VAR1C,30)=1,15,'小心注意'),LINETHICK1,COLORFFCC66;

STICKLINE(VAR1C AND COUNT(VAR1C,30)=1,0,10,5,0),COLORFFCC66;

该文观点仅代表作者本人,贝壳投研系信息发布平台

贝壳投研从多维度分析,整理了一份《成长50》的名单,可以关注同名公众号:"贝壳投研":Beiketouyan,进行领取(点击复制)

/阅读下一篇/

大智慧超牛KDJ指标公式,大智慧主力成本计算主图指标公式

可能感兴趣的
热门推荐