通达信波段买进指标公式,通达信短线黑马选股指标公式

股票公式 | 发布于2022-01-26

通达信波段买进指标公式

均5:MA(CLOSE,5), COLORYELLOW;

均10:MA(CLOSE,10), COLORF00FF0;

均30: MA(CLOSE,30), COLOR00FF00;

均60: MA(CLOSE, 60), COLORRED, POINTDOT ,LINETHICK2;

均250: MA(CLOSE, 250), COLORBLUE ,LINETHICK2 ;

上轨: 均30 + 2*stD(CLOSE,30), COLORYELLOW, POINTDOT, LINETHICK2,COLORLIGREEN ;

下轨: 均30 - 2*STD(CLOSE,30), COLORYELLOW ,POINTDOT ,LINETHICK2,COLORLIRED;

N:=13;

L0:=0.02;

L5:=Abs(L-REF(L,N))<=L0OR ABS(C-REF(L,N))<=L0OR ABS(O-REF(L,N))<=L0OR ABS(L-REF(O,N))<=L0OR ABS(C-REF(O,N))<=L0OR ABS(O-REF(O,N))<=L0OR ABS(L-REF(C,N))<=L0OR ABS(C-REF(C,N))<=L0OR ABS(O-REF(C,N))<=L0OR ABS(L-REF(H,N))<=L0OR ABS(C-REF(H,N))<=L0OR ABS(O-REF(H,N))<=L0;

精准线首次:= L5;

精准左:=FILTER(精准线首次,N) ;

天数:=BArslAST(精准左);

LTS:=REF(L,天数);

精准右:=ABS(L-LTS)<=L0;

STICKLINE(精准左,L,L,190,-1),COLORMAGENTA;

DRAWLINE(精准左,L,精准右,LTS,0),COLORMAGENTA;

JJ:=(CLOSE+HIGH+LOW)/3;

A:=EMA(JJ,7);

B:=REF(A,1);

STICKLINE(A>B,A,B,2,0),COLORMAGENTA;

STICKLINE(A<B,A,B,2,0),COLORGREEN;

M1:=EMA(CLOSE,3);

M2:=EMA(CLOSE,8);

M3:=EMA(M2,13);

M4:=EMA(M2,55);

VAR1:=EMA(M3,55);

M5:=EMA(M4,81), COLORRED,LINETHICK2;

VAR2:=(REF(HIGH,1)+REF(LOW,1))/2;

VAR3:=MA(CLOSE,21)+2*STD(CLOSE,21);

DRAWICON(crOSS(VAR2,VAR3),HIGH*1.035,2);

DRAWTEXT(CROSS(VAR2,VAR3),HIGH*1.02,''), COLORGREEN;

VAR4:=REF(CLOSE,1);

VAR5:=SMA(MAX(CLOSE-VAR4,0),7,1)/SMA(ABS(CLOSE-VAR4),7,1)*100;

VAR6:=CROSS(79,VAR5);

VAR7:=FILTER(VAR6,4);

DRAWICON(VAR7,HIGH*1.035,2);

DRAWTEXT(VAR7,HIGH*1.02,''), COLORGREEN;

A7:=(2*C+H+L)/4;

VAR10:=LLV(LOW,34);

VAR11:=HHV(HIGH,34);

SK:=EMA((A7-VAR1)/(VAR2-VAR1)*100,7);

SD:=EMA(0.667*REF(SK,1)+0.333*SK,5);

DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),8)/8>6/10 ANDvol>=1.5*MA(VOL,5) ANDCOUNT(SK>=SD,3) AND REF(LOW,1)=LLV(LOW,120),1,0),LOW,'●买进') ,COLORRED;

DRAWTEXT(IF(COUNT(CLOSE<REF(CLOSE,1),13)/13>6/10 ANDCOUNT(SK>SD,6) AND REF(LOW,5)=LLV(LOW,120) AND REF(CLOSE>=OPEN,4) ANDREF(CLOSE>OPEN,3) AND REF(CLOSE>OPEN,2) AND REF(OPEN>CLOSE,1) ANDOPEN>REF(CLOSE,1),1,0),LOW,'●买进'), COLORRED;

D:=MA(CLOSE,80)-MA(CLOSE,10)/3;

DRAWTEXT(IF(CLOSE<D AND VOL/240>MA(VOL,5)/240 AND CLOSE>REF(CLOSE,1)*1.08AND CLOSE<MA(CLOSE,13)*1.3,1,0) AND MA(C,120)>=REF(MA(C,120),1),LOW,'●抄底'),COLORRED;

通达信短线黑马选股指标公式

A0:=HHV(H,13)-LLV(L,13);

{13日最高价与最低价之差}A1:=HHV(H,13)-C;

{13日最高价与收盘价之差}A2:=C-LLV(L,13);

{收盘价与最低价之差}A3:= A1/A0*100-70;

{思路之高价差在整个差值中比例减掉70,即获取三成权重}A4:=(C-LLV(L,60))/(HHV(H,60)-LLV(L,60))*100;

{收盘价与60最低点距离,与60最高价最低价距离之比}A5:=(2*C+H+L)/4;

{今日均价收盘双倍权重}A6:=SMA(A2/A0*100,3,1);

{低价比例平滑处理}A7:=LLV(L,34);

{34日最低价}A8:=SMA(A6,3,1)-SMA(A3,9,1);

{再取移动平均,高出收盘部分与低于收盘部分的差距,两个不一致的权重?必要性?}A9:=IF(A8>100,A8-100,0);

{差距大于100的话,那么就要减掉100,}AA:=HHV(H,34);

{34日高价}AB:=A9*2;

{差距的两倍,是两条移动均线的距离}ac:=EMA((A5-A7) / (AA-A7)*100,13);

{34日高低价之间的比例关系平均移动曲线}AD:= EMA(0.667*REF(AC,1)+0.333*AC,2);

AE:=SMA(A4,20,1);

AF:=SMA(AB,2,1)-AB;

B0:=EMA(0.667*REF(AC,1)+0.333*AC,2)-AC;

B1:=(HHV(H,9)-C)/(HHV(H,9)-LLV(LOW,9))*100- 70;

B2:=SMA(B1,9,1)+100;

B3:=(C-LLV(L,9))/(HHV(H,9)- LLV(L,9))*100;

B4:=SMA(B3,3,1);

B5:=SMA(B4,3,1)+100;

B6:=B5-B2;

B7:=IF(B6>60,B6-60,0);

stICKLINE(REF(B7,1)<B7,B7,REF(B7,1),5,0),COLORRED;

STICKLINE(REF(B7,1)>B7,B7,REF(B7,1),5,0),COLORFFFF00;

主力:EMA((CLOSE-MA(CLOSE,7))/MA(CLOSE,7)*480,2),LINETHICK2,COLORRED;

散户:EMA((CLOSE-MA(CLOSE,11))/MA(CLOSE,11)*480,7),LINETHICK2,COLORWHITE;

DRAWTEXT(crOSS(主力,散户) AND 主力<-10,-20,'升'),COLORYELLOW;

DRAWICON(CROSS(主力,散户) AND 主力<-10 AND 散户>REF(散户,1)OR CROSS(主力,散户) AND 散户<-35 ,-15,1);

加速探底:IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,40,0.85),COLORYELLOW;

机会来临1:REF(IF(REF(C,1)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,40,0),1),COLOR9999FF;

A11:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,1);

黑马线:=EMA(A11,5);

A21:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100;

A31:=EMA(C,5);

A41:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;

趋势线:=(MA(3*SMA(A41,6,1)-2*SMA(SMA(A41,5,1),5,1),2));

A51:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;

DRAWTEXT(FILTER(REF(黑马线,1)>90 AND A21<0,7),黑马线,'跑'),COLOR00FF00;

DRAWTEXT(CROSS(A11,黑马线)AND 黑马线<A51,黑马线,'黑马'),COLORYELLOW;

DRAWTEXT(CROSS(黑马线,A51)AND趋势线<80,黑马线,'追涨'),COLOR688EC1;

DRAWTEXT(CROSS(趋势线,0)AND 黑马线<40,5,'大黑马 '),COLORFFFF00;

底部:=(A21<-10 AND A21>REF(A21,1))*25;

DRAWICON(底部 AND A31>REF(A31,1),25,1);

机会来临2:REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,65,0),1),COLORF00FF0;

飞鲸投研从多维度分析,整理了一份《成长50》的名单,可以关注同名公众号:"飞鲸投研":Beiketouyan,进行领取(点击复制)

该文观点仅代表作者本人,飞鲸投研系信息发布平台

/阅读下一篇/

通达信布林+均线+BBI主图指标公式,通达信穿越寻牛主图指标公式

可能感兴趣的
热门推荐