大智慧自用支压主图指标公式,大智慧资金大盘指标公式

股票公式 | 发布于2021-09-18

大智慧自用支压主图指标公式

input: N(5,1,100);

{DRAWGBKLAST(CLOSE>0,STRIP(RGB(95,95,95),RGB(0,0,0),0));

}主筹估算:=EMA(WINNER(c)*70,3);

散筹估算:=EMA((WINNER((c)*1.1)-WINNER((c)*0.9))*70,3);

筹码锁定:=散筹估算-主筹估算 ;

动态底部:=EMA(IF(L<= LLV(l,60),SMA(ABS(L-REF(L,1)),60,1)/SMA(MAX(L-REF(l,1),0),99,1),0)*5,3);

涨:=CROSS(主筹估算,筹码锁定);

强:=CROSS(主筹估算,散筹估算);

STICKLINE(涨,O,C,8,0),COLORYELLOW;

STICKLINE(涨,O,H,0,0),COLORYELLOW;

STICKLINE(涨,L,C,0,0),COLORYELLOW;

STICKLINE(强, O,C,8,0),colormagenta;

STICKLINE(强,O,H,0,0),colormagenta;

STICKLINE(强,L,C,0,0),colormagenta;

A1:=ref(h,N)=hhv(h,2*N+1);

B1:=filter(A1,N);

C1:=backset(B1,N+1);

D1:=filter(C1,n);

{高点}A2:=ref(l,N)=llv(l,2*N+1);

B2:=filter(A2,N);

C2:=backset(B2,N+1);

D2:=filter(C2,N);

{低点}E1:=(ref(llv(l,2*N),1)+ref(hhv(h,2*N),1))/2;

 E2:=(h+l)/2;

{高低点出现在同一K线上时可作取舍}H1:=(D1 AND not(D2 AND E1>=E2)) OR barstatus=2 OR barscount(c)=1;

L1:=(D2 AND not(D1 AND E1<E2)); 

H2:=D1 AND not(D2 AND E1>=E2);

X1:=ref(barslast(H1),1)+1;

 F1:=backset(H1 AND count(L1,X1)>0,llvbars(if(L1,l,10000),X1));

G1:=F1>ref(F1,1);

 I1:=backset(G1,2);

 LD:=I1>ref(I1,1);

{过滤后低点}L2:=LD OR barstatus=2 OR barscount(c)=1;

X2:=ref(barslast(L2),1)+1;

 F2:=backset(L2 AND count(H2,X2)>0,hhvbars(if(H2,h,0),X2));

G2:=F2>ref(F2,1);

 I2:=backset(G2,2); HD:=I2>ref(I2,1);

{过滤后高点}R1:=backset(barstatus=2,barslast(HD)+1); 

S1:=R1>ref(R1,1);

 {前一高}T1:=backset(barstatus=2,barslast(LD)+1);

 U1:=T1>ref(T1,1); 

{前一低}R2:=backset(S1,ref(barslast(HD),1)+2);

 S2:=R2>ref(R2,1); 

{前二高}T2:=backset(U1,ref(barslast(LD),1)+2);

U2:=T2>ref(T2,1);

 {前二低}T3:=backset(U2,ref(barslast(LD),1)+2); 

U3:=T3>ref(T3,1);

 {前三低}T4:=backset(U3,ref(barslast(LD),1)+2);

 U4:=T4>ref(T4,1);

 {前四低}R3:=backset(S2,ref(barslast(HD),1)+2);

 S3:=R3>ref(R3,1);

 {前三高}R4:=backset(S3,ref(barslast(HD),1)+2);

 S4:=R4>ref(R4,1); 

{前四高}短期压力:drawline(S2,h,S1,h,1),Colorred;

短期支撑:drawline(U2,l,U1,l,1),Colorgreen;

中期压力:drawline(S3,h,S2,h,1),Coloryellow;

中期支撑:drawline(U3,l,U2,l,0),Colorgreen;

长期压力:drawline(S4,h,S3,h,1),COLORwhite;

长期支撑:drawline(U4,l,U3,l,0),Colorgreen;

DRAWICON(S1,H*1.01,13);

DRAWICON(S2,H*1.01,13);

DRAWICON(S3,H*1.01,13);

DRAWICON(S4,H*1.01,13);

DRAWICON(U1,L*0.99,12);

DRAWICON(U2,L*0.99,12);

DRAWICON(U3,L*0.99,12);

DRAWICON(U4,L*0.99,12);

止损:=REF(c,1)*0.95;

DRAWTEXT(c>0 and BARSTATUS=2,h*1.03,'止损:'+NUMTOSTRN(止损,2)),ALIGN0,colorffffff;

HV:=HHV(V,30)=V OR V/REF(V,1)>=5 ;

FT:=BARSLAST(HV);

量能平台:if(HV,C,ref(C,FT)),COLORwhite,LINETHICK2;

drawtext(量能平台>ref(量能平台,1) and c>ref(c,1) and not(c>ma(c,13) and c=hhv(c,20) and c/ref(c,1)>1.05),c,'---------'+c),coloryellow;

drawtext(量能平台>ref(量能平台,1) and c<ref(c,1),c,'---------带量阴'+c),colorgreen;

{drawtext(量能平台<=ref(量能平台,1) and c<ref(c,1),c,'----------'+c),colorgreen;

}drawtext(量能平台<ref(量能平台,1) and c>ref(c,1),c,'---------缩量涨'+c),colorwhite;

drawtext(量能平台>ref(量能平台,1) and c>ref(c,1) and c>ma(c,13) and c=hhv(c,20) and c/ref(c,1)>1.05,c,'---------带量突破'+c),colorred;

ma(c,17);

大智慧资金大盘指标公式

主力持仓:EMA(100*(CLOSE-LLV(LOW,34))/(HHV(HIGH,34)-LLV(LOW,34)),3),COLORFF00FF,LINETHICK1;

CN1:=HHV(V,5);

{5日最高量}CN2:=O>C;

CN02:=C>O;

CN03:=C=O;

CN04:=((SUM(V,5)/CN1));

CN05:=IF(CN04>0.3,1,0);

{大资金}CN06:=IF(CN2 AND CN05,V,0);

{大资金流出}CN07:=IF(CN02 AND CN05,V,0);

{大资金流入}CN08:=IF(CN03 AND CN05,V,0);

{不明流向大资金}累积流入:SUM(CN07,9)/10000,coloryellow,LINETHICK0;

累积流出:SUM(CN06,9)/10000,colorblue,LINETHICK0;

净流入:(累积流入-累积流出),COLORffffff,LINETHICK0;

净流入角度:ATAN((净流入/REF(净流入,1)-1)*100)*57.3,LINETHICK0;

STICKLINE(累积流入,0 ,累积流入 ,8 ,1 ),COLORyellow;

STICKLINE(累积流出,0 ,累积流出 ,8 ,1 ),COLORblue;

{0AMV活筹指数}Var1:=AMOUNT/1000000;

Var2:=SMA(Var1,10,1);

Var3:=REF(Var2,1);

STICKLINE(Var2>Var3,Var2,Var3,7,0),colorred;

STICKLINE(Var2<Var3,Var2,Var3,7,0),colorgreen;  

Tags: 大智慧
该文观点仅代表作者本人,飞鲸投研系信息发布平台

飞鲸投研从多维度分析,整理了一份《成长50》的名单,可以关注同名公众号:"飞鲸投研":Beiketouyan,进行领取(点击复制)

/阅读下一篇/

大智慧无损波段指标公式,大智慧三皇赵易选股指标公式

可能感兴趣的
热门推荐