大智慧发现疯牛指标公式,大智慧布林线升级版主图指标公式

股票公式 | 发布于2021-09-15

大智慧发现疯牛指标公式

Var1:=DATE<1341231;

Var2:=(HIGH+LOW+OPEN+CLOSE)/4;

Var3:=EMA(Var2,13)-EMA(Var2,34);

Var4:=EMA(Var3,5);

Var5:=(Var3-Var4)*5;

Var6:=IF(Var5>=1000,1000,IF(Var5<=Var2,Var2,Var5));

分水岭: FORCAST(FORCAST(Var6,32),10)*Var1,LINETHICK2 ,COLOR339999;

上涨: IF(Var6>分水岭,Var6,分水岭)*Var1,Color0000FF;

支撑: REVERSE(上涨)+2*分水岭*Var1, COLOR0066FF;

下跌: IF(Var6<分水岭,Var6,分水岭)*Var1,COLORFF0000;

阻力: REVERSE(下跌)+2*分水岭*Var1,COLORFF0000;

超强势: MA(LOW,50)+2*STD(LOW,50)*Var1,LINETHICK1 , COLOR66CCCC;

Var7:REVERSE(Var2)+2*(MA(LOW,18)+1.6*STD(LOW,18)),COLORf0f000;

Var8:=(REF(HIGH,1)+(HIGH-REF(HIGH,1))*VOL/CAPITAL)*1.095;

EMA(Var8,150)*Var1,POINTDOT ,COLORf00ff0,LINETHICK2;

EMA(Var8,6)*Var1,POINTDOT , COLOR339999,LINETHICK2;  

大智慧布林线升级版主图指标公式

DRAWGBK(c>=0),Color2B5516;

平衡:EMA(C,20),CIRCLEDOT,COLORwhite;

上轨:平衡 + 2*STD(C,20),LINETHICK2,COLORFF00FF;

下轨:平衡 - 2*STD(C,20),LINETHICK2,COLOR00ff00;

STICKLINE((CLOSE >平衡),平衡,平衡,1,0),LINETHICK6,color0000ff;

STICKLINE((平衡 > CLOSE),平衡,平衡,1,0),LINETHICK6,colorff6600;

STICKLINE(CLOSE>OPEN,OPEN,LOW,0.5,0 ),COLOR0000FF;

STICKLINE(CLOSE>OPEN,CLOSE,HIGH,0.5 ,0 ),COLOR0000FF;

STICKLINE(OPEN>=CLOSE,CLOSE,LOW,0.5 ,0 ),COLOR00FF00;

STICKLINE(OPEN>=CLOSE,OPEN,HIGH,0.5 ,0 ),COLOR00FF00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,7,0 ),COLORff7700;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,6,0 ),COLORff9900;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,5,0 ),COLORffbb00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,4,0 ),COLORffcc00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,3,0 ),COLORffdd00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,2,0 ),COLORffee00;

STICKLINE(OPEN>=CLOSE ,CLOSE ,OPEN,1,0 ),COLORffFF00;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7,0) ,COLOR000055;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000066;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR000077;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR000099;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,3,0) ,COLOR0000bb;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2,0) ,COLOR0000dd;

STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000ff;

var9Q:=c= hhv(c,4)and (ref(c,1)>=ref(c,2) or ref(c,1)>=ref(c,3)) or ref(c,1)=hhv(c,4) and close>=ref(c,2) or ref(c,2)=hhv(c,4) and ref(c,3)=llv(c,4) and c>=ref(c,1) or ref(c,3)=hhv(c,4) and c>=ref(c,1) and c>=ref(c,2);

stickline(var9Q,c,(o+c)/2,7,0),color000055;

stickline(var9Q,c,(o+c)/2,6,0),color000066;

stickline(var9Q,c,(o+c)/2,5,0),color000077;

stickline(var9Q,c,(o+c)/2,4,0),color000099;

stickline(var9Q,c,(o+c)/2,3,0),color0000bb;

stickline(var9Q,c,(o+c)/2,2,0),color0000dd;

stickline(var9Q,c,(o+c)/2,1,0),color0000ff;

varaQ:=c=hhv(c,4) and ref(c,1)=llv(c,4);

stickline(varaQ,c,(o+c)/2,7,0),colorff11ff;

stickline(varaQ,c,(o+c)/2,6,0),colorff33ff;

stickline(varaQ,c,(o+c)/2,5,0),colorff55ff;

stickline(varaQ,c,(o+c)/2,4,0),colorff77ff;

stickline(varaQ,c,(o+c)/2,3,0),colorff99ff;

stickline(varaQ,c,(o+c)/2,2,0),colorffbbff;

stickline(varaQ,c,(o+c)/2,1,0),colorffddff;

varbQ:=c=llv(c,4) and (ref(c,1)<ref(c,2) or ref(c,1)<ref(c,3)) or ref(c,1)=llv(c,4) and c<ref(c,2) or ref(c,2)=llv(c,4) and ref(c,1)<>hhv(c,4) and c<ref(c,1) or ref(c,3)=llv(c,4) and c<ref(c,1) and c<ref(c,2);

stickline(varbQ,c,(o+c)/2,7,0),color333333;

stickline(varbQ,c,(o+c)/2,6,0),color555555;

stickline(varbQ,c,(o+c)/2,5,0),color777777;

stickline(varbQ,c,(o+c)/2,4,0),color999999;

stickline(varbQ,c,(o+c)/2,3,0),colorbbbbbb;

stickline(varbQ,c,(o+c)/2,2,0),colordddddd;

stickline(varbQ,c,(o+c)/2,1,0),colorffffff;

varcQ:=ref(c,1)=llv(c,4) and c>=ref(c,2) or ref(c,2)=llv(c,4) and ref(c,1)<=ref(c,3) and ref(c,2)<ref(c,4) and c>=ref(c,1);

stickline(varcQ,o,(o+c)/2,7,0),color003300;

stickline(varcQ,o,(o+c)/2,6,0),color005500;

stickline(varcQ,o,(o+c)/2,5,0),color007700;

stickline(varcQ,o,(o+c)/2,4,0),color009900;

stickline(varcQ,o,(o+c)/2,3,0),color00bb00;

stickline(varcQ,o,(o+c)/2,2,0),color00dd00;

stickline(varcQ,o,(o+c)/2,1,0),color00ff00;

vardQ:=ref(c,1)=hhv(c,4) and c<ref(c,2) or (ref(c,2)=hhv(c,4) and ref(c,1)>ref(c,3) or ref(c,3)=hhv(c,4) and ref(c,1)>ref(c,2)) and ref(c,2)>=ref(c,4) and c<ref(c,1);

stickline(vardQ,o,(o+c)/2,7,0),colorff1100;

stickline(vardQ,o,(o+c)/2,6,0),colorff3300;

stickline(vardQ,o,(o+c)/2,5,0),colorff5500;

stickline(vardQ,o,(o+c)/2,4,0),colorff7700;

stickline(vardQ,o,(o+c)/2,3,0),colorff9900;

stickline(vardQ,o,(o+c)/2,2,0),colorffbb00;

stickline(vardQ,o,(o+c)/2,1,0),colorffdd00;

Y1:=REF(EMA(DMA((((HIGH + LOW) + (CLOSE * 2)) / 4.15),0.9),3),1);

DRAWtext(CROSS(CLOSE,Y1),LOW,'[买进]'),ColorYELLOW;

STICKLINE(CROSS(Y1,CLOSE),h*1.05,h,1,0),COLORwhite;

DRAWtext(CROSS(Y1,CLOSE),HIGH*1.05,'[卖出]'),colorwhite;

VAR1w:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));

VAR2w:=(100 - ((90 * (HHV(HIGH,21) - CLOSE)) / (HHV(HIGH,21) - LLV(LOW,21))));

VAR3w:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));

DRAWTEXT(CROSS(VAR2w,MA(VAR3w,6)),LOW -0.6,'(买)'),colorFF99FF;

DRAWTEXT(CROSS(MA(VAR3w,6),VAR1w),HIGH +0.9,'(卖)'),colorccFF13;

Var3p:=IF(CLOSE/REF(CLOSE,1)>1.050 AND HIGH/CLOSE<1.010 AND IF(CLOSE>REF(CLOSE,1),88,0)>0, 91, 0);

STICKLINE(Var3p>90,L,L*0.92,1,0),COLORff00ff;

DRAWTEXT(Var3p>90,LOW*0.92,'追涨'),COLORFF00FF;

Ss:=MA((LOW+HIGH+CLOSE)/3,5)>REF(MA((LOW+HIGH+CLOSE)/3,5),1) AND REF(MA((LOW+HIGH+CLOSE)/3,5),1)<REF(MA((LOW+HIGH+CLOSE)/3,5),2);

SC:=L<HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND H>HHV(MA((LOW+HIGH+CLOSE)/3,5),13) AND C>REF(C,1) AND C>O;

MR:=SC AND COUNT(Ss,2);

买:=MR AND NOT(REF(MR,1)){,coloryellow};

STICKLINE(买,L,L*0.95,1,0),COLORred;

DRAWTEXT(买,L*0.95, '必涨'),COLORred;

多方:=7*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1)-3*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1)-SMA(SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*30,4,1),3,1),2,1);

STICKLINE(CROSS(78.89,多方),h+1.5,h,1,0),COLOR00FF00;

DRAWTEXT(CROSS(78.89,多方),H+1.5,'(逃顶)'),COLOR00FF00;

A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*1,5,1){,color330066};

A2:=(EMA(A1,5)-REF(EMA(A1,5),1))/REF(EMA(A1,5),1)*1;

A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*1;

DRAWTEXT(CROSS(A1,EMA(A1,5))AND EMA(A1,5)<A5,l*0.98,'(黑马)'),COLORyellow;

Var1:=(CLOSE-LLV(LOW,24))/(HHV(HIGH,24)-LLV(LOW,24))*1;

Var2:=SMA(Var1,3,1)*100;

趋势线:=SMA((SMA(Var2,3,1)*var1),3,1)*1;

Var9:=CROSS(趋势线,(SMA(Var2,3,1)*var1)) AND (SMA(Var2,3,1)*var1)>8;

DRAWTEXT(Var9 AND COUNT(Var9,1)=1,h+0.6,'逃'), linethick2,COLORYELLOW;

DRAWICON(FILTER(CROSS(-"W&R.wr1"(14,14),(0 - 81)),10),L-0.2,1);

DRAWICON(FILTER(CROSS((0 -19),-"W&R.wr1"(14,14)),10),H,2);

DRAWTEXTREL(150,30,'指示:红持股 粉变盘 绿买进 蓝抛出 灰下跌'),COLORred;  

该文观点仅代表作者本人,贝壳投研系信息发布平台

贝壳投研从多维度分析,整理了一份《成长50》的名单,可以关注同名公众号:"贝壳投研":Beiketouyan,进行领取(点击复制)

/阅读下一篇/

认股权证是什么意思?股票里权证是什么意思?权证的权证历史

可能感兴趣的
热门推荐