大智慧K线形态主图指标公式,大智慧金线不破主图指标公式

股票公式 | 发布于2021-09-15

大智慧K线形态主图指标公式

P1:=30;

P2:=6;

P3:=3;

P4:=250;

DRAWGBKLAST(CLOSE>0,'a008');

if DISPSTATUS=2 then aaa:=BARPOS;

if DISPSTATUS=1 then bbb:=BARPOS;

ddd:=aaa-bbb;

ee:=hhv(h,ddd);

TJTS:=BARSTATUS=2;

早晨之星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.03 ANDCLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);

黄昏之星:=REF(CLOSE,2)/REF(OPEN,2) > 1.03 AND REF(OPEN,1) > REF(CLOSE,2) AND ABS(REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<0.02 AND CLOSE/OPEN<0.97 AND CLOSE<REF(CLOSE,2);

长十字:=CLOSE=OPEN AND HIGH/LOW >1.03;

垂死十字:=CLOSE=OPEN AND CLOSE=LOW AND CLOSE<>HIGH;

早晨十字星:=REF(CLOSE,2)/REF(OPEN,2) < 0.95 AND REF(OPEN,1) < REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) ANDCLOSE/OPEN>1.05 AND CLOSE>REF(CLOSE,2);

黄昏十字星:=REF(CLOSE,2)/REF(OPEN,2) > 1.05 AND REF(OPEN,1) > REF(CLOSE,2) AND REF(OPEN,1)=REF(CLOSE,1) ANDCLOSE/OPEN<0.95 AND CLOSE<REF(CLOSE,2);

射击之星:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE > MA(CLOSE,5);

倒转锤头:=MIN(OPEN,CLOSE)=LOW AND HIGH-LOW > 3*(MAX(OPEN,CLOSE)-LOW) AND CLOSE < MA(CLOSE,5);

锤头:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE < MA(CLOSE,5);

吊颈:=HIGH = MAX(OPEN,CLOSE) AND HIGH-LOW > 3*(HIGH-MIN(OPEN,CLOSE)) AND CLOSE>MA(CLOSE,5);

穿头破脚:=(REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.96 AND CLOSE<REF(OPEN,1) AND OPEN>REF(CLOSE,1))OR (REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.04 AND CLOSE>REF(OPEN,1) AND OPEN<REF(CLOSE,1));

乌云盖顶:=REF(CLOSE,1)/REF(OPEN,1)>1.03 AND CLOSE/OPEN<0.97 AND OPEN>REF(CLOSE,1) AND CLOSE<REF(CLOSE,1);

曙光初现:=REF(CLOSE,1)/REF(OPEN,1)<0.97 AND CLOSE/OPEN>1.03 AND OPEN<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1);

身怀六甲:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND ABS(CLOSE-OPEN)/CLOSE<0.005 ANDMAX(CLOSE,OPEN) < MAX(REF(CLOSE,1),REF(OPEN,1)) AND MIN(CLOSE,OPEN) > MIN(REF(CLOSE,1),REF(OPEN,1));

十字胎:=ABS(REF(CLOSE,1)-REF(OPEN,1))/REF(CLOSE,1) > 0.04 AND CLOSE=OPEN ANDCLOSE < MAX(REF(CLOSE,1),REF(OPEN,1)) AND CLOSE > MIN(REF(CLOSE,1),REF(OPEN,1));

平顶:=ABS(HIGH-REF(HIGH,1))/HIGH<0.001;

平底:=(ABS(LOW-REF(LOW,1))/LOW<0.001 and abs(ref(low,1)-ref(low,2))/ref(low,1)<=0.001);

大阳烛:=CLOSE/OPEN>1.05 AND HIGH/LOW < CLOSE/OPEN+0.018;

三个白武士:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND CLOSE>OPENAND REF(CLOSE,1)>REF(CLOSE,2) AND CLOSE>REF(CLOSE,1);

双飞乌鸦:=REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND CLOSE/OPEN<0.98;

孕育线:=REF(CLOSE,2)>REF(OPEN,2) AND (REF(CLOSE,2)-REF(OPEN,2))/REF(OPEN,2)>=2/100 AND REF(OPEN,1)>=REF(CLOSE,1) AND (REF(OPEN,1)-REF(CLOSE,1))/REF(CLOSE,1)<=2/100 AND REF(OPEN,1)<=REF(CLOSE,2) AND REF(CLOSE,1)>=REF(OPEN,2) AND C>=OPEN AND (CLOSE-OPEN)/OPEN>=2/100 AND CLOSE>=REF(OPEN,1) AND OPEN<=REF(CLOSE,1) AND (MAX(CLOSE,REF(C,2))-MIN(CLOSE,REF(CLOSE,2)))/MIN(CLOSE,REF(CLOSE,2))<=1/100;

多方炮:=REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN;

出水芙蓉:=(OPEN<EMA(C,20) OR OPEN<EMA(C,40) OR OPEN<EMA(C,60)) AND (C>MAX(EMA(C,20),MAX(EMA(C,40),EMA(C,60))))AND (V/MA(V,30)>1.2 AND C/REF(C,1)>1.049);

上升三部曲:=REF(CLOSE,4)/REF(OPEN,4)>1.03 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) AND REF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) ANDREF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN>1.03 AND CLOSE>REF(CLOSE,4);

下跌三部曲:= REF(CLOSE,4)/REF(OPEN,4)<0.97 AND REF(CLOSE,3)>REF(OPEN,3) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(CLOSE,1)>REF(OPEN,1) AND REF(LOW,4)<REF(LOW,3) ANDREF(LOW,4)<REF(LOW,2) AND REF(LOW,4)<REF(LOW,1) AND REF(HIGH,4)>REF(HIGH,3) AND REF(HIGH,4)>REF(HIGH,2) AND REF(HIGH,4)>REF(HIGH,1) AND CLOSE/OPEN<0.97 ANDCLOSE<REF(CLOSE,4);

跳空缺口:=HIGH<REF(LOW,1) OR LOW>REF(HIGH,1);

三只乌鸦:=REF(CLOSE,2)<REF(OPEN,2) AND REF(CLOSE,1)<REF(OPEN,1) AND CLOSE<OPEN AND REF(CLOSE,1)<REF(CLOSE,2) AND CLOSE<REF(CLOSE,1);

光脚阴线:=LOW=CLOSE AND HIGH<>LOW;

光头阳线:=HIGH=CLOSE AND HIGH<>LOW;

分离:=OPEN=REF(OPEN,1) AND (CLOSE-OPEN)*(REF(CLOSE,1)-REF(OPEN,1))<0;

长下影:=(MIN(CLOSE,OPEN)-LOW)/(HIGH-LOW)>0.667;

长上影:=(HIGH-MAX(CLOSE,OPEN))/(HIGH-LOW)>0.667;

十字星:=CLOSE=OPEN AND HIGH<>LOW;

大阴烛:=OPEN/CLOSE > 1.05 AND HIGH/LOW < OPEN/CLOSE+0.018;

好友反攻:=(REF(CLOSE,1)<REF(OPEN,1) AND CLOSE>OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002)OR (REF(CLOSE,1)>REF(OPEN,1) AND CLOSE<OPEN AND ABS(CLOSE-REF(CLOSE,1))/CLOSE<0.002);

倾盆大雨:=REF(C,1)/REF(O,1)>=1.03 AND O<REF(C,1) AND O>REF(O,1) AND C<REF(O,1);

i:=0;

IF 倾盆大雨 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'倾盆大雨,见顶信号‖'),ALIGN2; 

i:=i+0.03; 

ENDIF 大阴烛 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'大阴烛,后市向淡,发生逆转‖'),COLORCYAN,ALIGN2;

 i:=i+0.03; 

ENDIF 好友反攻 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'好友反攻,跌势已尽,要展开一段反弹行情‖'),COLORRED,ALIGN2;

 i:=i+0.03;

 ENDIF 跳空缺口 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'跳空缺口,突破长期盘整,向上跳空,上涨行情开始;

向下跳空,下跌行情开始‖'),COLORWHITE,ALIGN2;

 i:=i+0.03;

 ENDIF 光脚阴线 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'光脚阴线,下跌信号‖'),COLORCYAN,ALIGN2;

 i:=i+0.03;

 ENDIF 光头阳线 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'光头阳线,多方积极上攻态势,后市看涨‖'),COLORRED,ALIGN2;

 i:=i+0.03; 

ENDIF 三只乌鸦 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'三只乌鸦站枝头,可能见顶回落‖'),COLORCYAN,ALIGN2;

 i:=i+0.03; 

ENDIF 分离 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'分离,注意看涨分离和看跌分离‖'),COLORWHITE,ALIGN2;

 i:=i+0.03; 

ENDIF 长下影 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'长下影,持续下跌后出现,有可能止跌回升;

在升势末期出现,须多加留意‖'),COLORRED,ALIGN2;

 i:=i+0.03;

 ENDIF 长上影 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'长上影,表明行情上档压力沉重,升势受阻‖'),COLORCYAN,ALIGN2; 

i:=i+0.03; 

ENDIF 下跌三部曲 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'下跌三部曲,下跌信号‖'),COLORRED,ALIGN2;

 i:=i+0.03;

 ENDIF 上升三部曲 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'上升三部曲,上涨信号‖'),COLORCYAN,ALIGN2;

 i:=i+0.03;

 ENDIF 早晨之星 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'早晨之星,见底回升‖'),COLORRED,ALIGN2

; i:=i+0.03; 

ENDIF 黄昏之星 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'黄昏之星,见顶回落‖'),COLORCYAN,ALIGN2;

 i:=i+0.03;

 ENDIF 十字星 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'十字星,重要的警告信号,原趋势停顿或反转‖'),COLORWHITE,ALIGN2;

 i:=i+0.03;

 ENDIF 长十字 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'长十字,重要的警告信号,原趋势停顿或反转‖'),COLORWHITE,ALIGN2;

 i:=i+0.03; 

ENDIF 垂死十字 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'垂死十字,下跌信号‖'),COLORCYAN,ALIGN2;

 i:=i+0.03; 

ENDIF 早晨十字星 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'早晨十字星,上涨信号,见底回升‖'),COLORRED,ALIGN2;

 i:=i+0.03;

 ENDIF 黄昏十字星 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'黄昏十字星,趋势停顿或反转,下跌信号,见顶回落‖'),COLORCYAN,ALIGN2;

 i:=i+0.03;

 ENDIF 射击之星 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'射击之星,出现在短期的上升趋势,表明市场顶部就在眼前,可能见顶回落,可靠性低‖'),COLORCYAN,ALIGN2; 

i:=i+0.03; 

ENDIF 倒转锤头 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'倒转锤头构成一个看涨信号,可能见底回升‖'),COLORRED,ALIGN2;

 i:=i+0.03;

 ENDIF 锤头 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'锤头,可能见底回升,如有量配合,信号强烈‖'),COLORRED,ALIGN2;

 i:=i+0.03; 

ENDIF 吊颈 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'吊颈,上升行情中见顶回落,顶部出现,见顶信号‖'),COLORCYAN,ALIGN2; 

i:=i+0.03;

 ENDIF 平顶 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'平顶,意味行情摸高见顶,股价行将反转。但反转下跌力度较小‖'),COLORCYAN,ALIGN2;

 i:=i+0.03;

 ENDIF 穿头破脚 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'穿头破脚,顶部出现,见顶回落信号‖'),COLORCYAN,ALIGN2;

 i:=i+0.03;

 ENDIF 乌云盖顶 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'乌云盖顶,见顶回落信号‖'),COLORCYAN,ALIGN2;

 i:=i+0.03;

 ENDIF 曙光初现 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'曙光初现,行情将演化为V型反转或止跌横盘趋势。后市见底回升‖'),COLORRED,ALIGN2;

 i:=i+0.03;

 ENDIF 身怀六甲 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'身怀六甲,出现在底部,是见底回升信号;

出现在顶部,是见顶回落信号‖'),COLORRED,ALIGN2;

 i:=i+0.03;

 ENDIF 十字胎 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'十字胎‖'),COLORRED,ALIGN2; 

i:=i+0.03;

 ENDIF 平底 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'平底,行情探低见底,股价行将反转上升,但力度较小‖'),COLORRED,ALIGN2; 

i:=i+0.03;

 ENDIF 大阳烛 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'大阳烛,在上升行情中出现,则意味着行情剧烈地向上攀升。在下跌行情中出现,则意味着行情剧烈地向上反弹‖'),COLORRED,ALIGN2;

 i:=i+0.03; 

ENDIF 三个白武士 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'三个白武士,每日收盘价上移,表示可能见底回升‖'),COLORRED,ALIGN2;

 i:=i+0.03;

 ENDIF 双飞乌鸦 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'双飞乌鸦,行情开始疲软将见顶回落‖'),COLORCYAN,ALIGN2;

 i:=i+0.03;

 ENDIF 孕育线 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'孕育线,注意股价位置‖'),COLORWHITE,ALIGN2;

 i:=i+0.03;

 ENDIF 多方炮 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'多方炮,在底部出现有上涨可能,在中间出现有可能是上涨中继,顶部出现是复合见顶信号‖'),COLORRED,ALIGN2;

 i:=i+0.03;

 ENDIF 出水芙蓉 AND TJTS THEN BEGIN DRAWTEXT(c>0,ee*(1.1-i),'出水芙蓉,阳线穿过20、40、60日季均线,上攻势头初现‖'),COLORRED,ALIGN2;

 i:=i+0.03;

 END;

Var1:=(C+L+H)/3;

Var2:=eMA(Var1,6);

Var3:=eMA(Var2,5);

Var4:=eMA(Var3,12);

Var5:=eMA(Var4,5);

生命线:eMA(Var3,30),COLORRED,POINTDOT;

DRAWICON(C>=生命线,生命线,9);

DRAWICON(C<生命线,生命线,10);

a:=HHV(MA((L+H+C)/3,3),3);

b:=llv(MA((L+H+C)/3,3),10);

STICKLINE(DISPSTATUS=2,a,a,20,0),Coloryellow,linethick3;

DRAWTEXT(DISPSTATUS=2 ,a,NUMTOSTRN(a,3)),colorYELLOW;

STICKLINE(DISPSTATUS=2,b,b,20,0),ColorDB3FDD,linethick3;

DRAWTEXT(DISPSTATUS=2,b,NUMTOSTRN(b,3)),ColorDB3FDD;

k1:=llv(l,barslast(DISPSTATUS=1)+1);

aa1:=cost(95);

aa2:=cost(5);

ly:=(aa1-aa2)*100/(aa1+aa2);

DRAWTEXT(ly>ref(ly,1),k1,'▲'),Color0000FF;

N:=p1;

{原码 N:=3;

}A1:=REF(H,N)=HHV(H,2*N+1);

 B1:=FILTER(A1,N); 

C1:=BACKSET(B1,N+1);

 D1:=FILTER(C1,N);

{高点}A2:=REF(L,N)=LLV(L,2*N+1);

 B2:=FILTER(A2,N); 

C2:=BACKSET(B2,N+1); 

D2:=FILTER(C2,N);

{低点}E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2; 

E2:=(H+L)/2;

{高低点出现在同一K线上时可作取舍}H1:=(D1 AND NOT(D2 AND E1>=E2)) OR DISPSTATUS=2 OR BARSCOUNT(C)=1;

L1:=(D2 AND NOT(D1 AND E1<E2));

 H2:=D1 AND NOT(D2 AND E1>=E2);

X1:=REF(BARSLAST(H1),1)+1; 

F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));

G1:=F1>REF(F1,1); 

I1:=BACKSET(G1,2); 

LD:=I1>REF(I1,1);

{过滤后低点}L2:=LD OR DISPSTATUS=2 OR BARSCOUNT(C)=1;

X2:=REF(BARSLAST(L2),1)+1;

 F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));

G2:=F2>REF(F2,1); 

I2:=BACKSET(G2,2); 

HD:=I2>REF(I2,1);

{过滤后高点}R1:=BACKSET(DISPSTATUS=2,BARSLAST(HD)+1); 

S1:=R1>REF(R1,1); 

{前一高}T1:=BACKSET(DISPSTATUS=2,BARSLAST(LD)+1); 

U1:=T1>REF(T1,1); 

{前一低}R2:=BACKSET(S1,REF(BARSLAST(HD),1)+2); 

S2:=R2>REF(R2,1);

 {前二高}T2:=BACKSET(U1,REF(BARSLAST(LD),1)+2);

 U2:=T2>REF(T2,1);

 {前二低}T3:=BACKSET(U2,REF(BARSLAST(LD),1)+2);

 U3:=T3>REF(T3,1);

 {前三低}T4:=BACKSET(U3,REF(BARSLAST(LD),1)+2);

 U4:=T4>REF(T4,1);

 {前四低}R3:=BACKSET(S2,REF(BARSLAST(HD),1)+2); 

S3:=R3>REF(R3,1);

 {前三高}R4:=BACKSET(S3,REF(BARSLAST(HD),1)+2);

 S4:=R4>REF(R4,1);

 {前四高}DRAWLINE(S2,H,S1,H,1),Color80FFFF;

 {★压力1:}DRAWLINE(U2,L,U1,L,1),POINTDOT,Color00FFFF,linethick2;

{★支撑1:}DRAWLINE(S3,H,S2,H,1),ColorFF8000;

 {★压力2:}DRAWLINE(U3,L,U2,L,1),POINTDOT,ColorFF8000;

{★支撑2:}DRAWLINE(S4,H,S3,H,1),Color0000FF;

{★压力3:}DRAWLINE(U4,L,U3,L,1),POINTDOT,Color0000FF;

{★支撑3:};

DRAWICON(S2,H*1.01,9); 

DRAWICON(S3,H*1.01,9);

DRAWTEXT(S2,H*1.02,NUMTOSTRN(H,2)),COLORMAGENTA;

DRAWTEXT(S1,H*1.02,NUMTOSTRN(H,2)),COLORMAGENTA;

DRAWTEXT(S3,H*1.02,NUMTOSTRN(H,2)),COLORMAGENTA;

DRAWICON(U1,L*0.99,10); 

DRAWICON(U2,L*0.99,10);

DRAWICON(U3,L*0.99,10);

DRAWICON(U4,L*0.99,10);

DRAWTEXT(U1,L*0.98,NUMTOSTRN(L,2)),COLORCYAN;

DRAWTEXT(U2,L*0.98,NUMTOSTRN(L,2)),COLORCYAN;

DRAWTEXT(U3,L*0.98,NUMTOSTRN(L,2)),COLORCYAN;

DRAWTEXT(U4,L*0.98,NUMTOSTRN(L,2)),COLORCYAN;

STICKLINE(open>=close ,close ,open,0,0 ),COLOR00FF00;

STICKLINE(open>=close ,close ,open,8,0 ),COLOR008800;

STICKLINE(open>=close ,close ,open,7,0 ),COLOR009900;

STICKLINE(open>=close ,close ,open,6,0 ),COLOR00AA00;

STICKLINE(open>=close ,close ,open,5,0 ),COLOR00BB00;

STICKLINE(open>=close ,close ,open,4,0 ),COLOR00CC00;

STICKLINE(open>=close ,close ,open,3,0 ),COLOR00DD00;

STICKLINE(open>=close ,close ,open,2,0 ),COLOR00EE00;

STICKLINE(open>=close ,close ,open,1,0 ),COLOR00FF00;

STICKLINE(close>open,close,open,0,0) ,COLORFFBBFF;

STICKLINE(close>open,close,open,8,0) ,COLORFF00FF;

STICKLINE(close>open,close,open,7,0) ,COLORFF22FF;

STICKLINE(close>open,close,open,6,0) ,COLORFF44FF;

STICKLINE(close>open,close,open,5,0) ,COLORFF66FF;

STICKLINE(close>open,close,open,4,0) ,COLORFF88FF;

STICKLINE(close>open,close,open,3,0) ,COLORFF99FF;

STICKLINE(close>open,close,open,2,0) ,COLORFFAAFF;

STICKLINE(close>open,close,open,1,0) ,COLORFFBBFF;  

大智慧金线不破主图指标公式

IF(FINANCE2(37)/10000>=100) THEN BEGINDRAWTEXTREL(0,950,'【超大盘0.7%】 流通A股'+FINANCE2(37)/10000+'亿股'),LINETHICK2,ColorFF00FF;

 end;

IF(FINANCE2(37)/10000<100 and FINANCE2(37)/10000>=10) THEN BEGINDRAWTEXTREL(0,950,'【大盘股9.0%】 流通A股'+FINANCE2(37)/10000+'亿股'),LINETHICK2,ColorFF00FF; 

end;

IF(FINANCE2(37)/10000<10 and FINANCE2(37)/10000>=5) THEN BEGINDRAWTEXTREL(0,950,'【中盘股12.7%】 流通A股'+FINANCE2(37)/10000+'亿股'),LINETHICK2,ColorFF00FF;

 end;

IF(FINANCE2(37)/10000<5 and FINANCE2(37)/10000>=1) THEN BEGINDRAWTEXTREL(0,950,'【小盘股55.3%】 流通A股'+FINANCE2(37)/10000+'亿股'),LINETHICK2,ColorFF00FF; 

end;

IF(FINANCE2(37)/10000<1) THEN BEGINDRAWTEXTREL(0,950,'【超小盘22.3%】 流通A股'+FINANCE2(37)/10000+'亿股'),LINETHICK2,ColorFF00FF; 

end;

AA1:=AMOUNT/V;

BB1:=L<AA1*0.9;

CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;

DD1:=L<MA(C,5)*0.921;

EE1:=V<MA(V,5)*1.5;

FF1:=BB1 AND CC1 AND DD1 AND EE1;

DRAWTEXT(ff1,(LOW* 0.99),'↖鼠'),Color4080FF;

STICKLINE(ff1,O,C,6,0),COLORyellow;

STICKLINE(ff1,O,C,2.5,0),COLORred;

MTM:=C-REF(C,1);

DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(ABS(MTM),6),6);

买:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);

DRAWTEXT(filter(买=1,5),LOW-0.08,'↖低') ,COLORAAAAFF;

STICKLINE(filter(买=1,5),O,C,6,0),COLORyellow;

STICKLINE(filter(买=1,5),O,C,2.5,0),COLORred;

cc:=(h-c)/(c-o)<0.33;

dd:=(c/ref(c,1)-1)>=0.0502 and c>ref(c,1) and (o-l)/(c-o)>=1.48 and l<ref(l,1) and l<ref(l,2);

ee:=(c/ref(c,1)-1)>=0.08;

aa:=VOL>REF(VOL,1)*1.9 and c>ref(c,1) and c/ref(c,1)-1>=0.049 and cc;

bb:=(c/ref(c,1)-1)>=0.0502 and c>ref(c,1) and v>ref(v,1) and VOL>REF(VOL,1)*2.5 and cc;

DRAWTEXT(FILTER(aa or bb or dd or ee,34),l,'↖异动'),COLOrffff00;

STICKLINE(FILTER(aa or bb or dd or ee,34),O,C,6,0),COLORyellow;

STICKLINE(FILTER(aa or bb or dd or ee,34),O,C,2.5,0),COLORRED;

AAA:=(3*C+H+L+O)/6;

VAR41:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36;

TJ1:=VOL=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR41;

立桩量:=FILTER(TJ1,5);

TJ2:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(HIGH,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(HIGH,3),1,0)));

突破:=TJ2=1;

TJ3:=IF(BARSLAST(立桩量)=1 AND CLOSE>REF(LOW,1),1,IF(BARSLAST(立桩量)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(立桩量)=3 AND CLOSE>REF(LOW,3),1,0)));

三天法则:=TJ3=1;

成立:=三天法则 AND 突破;

条件成立:=FILTER(成立,3);

DRAWTEXT(条件成立,L*0.97,'↖立桩量'),COLORYELLOW;

VAR1111:=BACKSET(REF(HIGH,2)=HHV(HIGH,5),3);

VAR2222:=CROSS(VAR1111,0.9);

压力:= REF(HIGH,BARSLAST(VAR2222));

STICKLINE(CLOSE,REF(HIGH,BARSLAST(VAR2222)),REF(HIGH,BARSLAST (VAR2222)),0.5,1),COLOREA91B5,LINETHICK1;

STICKLINE(CLOSE<OPEN and ref(CLOSE,1)>ref(OPEN,1),ref(close,1),ref(close,1),33,0),COLORwhite,LINETHICK1;

DD:=FINANCE2(35);

SS:=FINANCE2(37);

GG:=FINANCE2(3);

TH:=DYNAINFO(39);

DRAWTEXTREL(0,70,'总股本:'+NUMTOSTRn(DD,0)+'万股' +' 流通A股:'+NUMTOSTRn(SS,0)+'万股'+' 市盈率:'+NUMTOSTRn(TH,2)+' 倍'+' 每股收益:'+NUMTOSTRn(GG,3)+' 元'),ColorFFFF00;

gj:=if(c=INDEXC,(INDEXC+INDEXh+INDEXl+INDEXO)/4,AMOUNT/(v+0.01)/100);

明日阻力:=l+(gj-l)+(c-l);

明日支撑:=l+(c-gj);

今日阻力:=REF(明日阻力 , 1);

日支撑:=REF(明日支撑 , 1);

STICKLINE(DISPSTATUS=2 and c>=今日阻力,今日阻力,今日阻力,20,0),Color0000FF;

STICKLINE(DISPSTATUS=2 and c<今日阻力,今日阻力,今日阻力,20,0),Color00FF00;

STICKLINE(DISPSTATUS=2 and c>=今日支撑,今日支撑,今日支撑,20,0),ColorFF00FF;

STICKLINE(DISPSTATUS=2 and c<今日支撑,今日支撑,今日支撑,20,0),ColorFF9900;

DRAWTEXTREL(850,890,'今日支撑:'+NUMTOSTRN(今日支撑 ,2 )),Colorred;

DRAWTEXTREL(850,950,'今日阻力:'+NUMTOSTRN(今日阻力 ,2 )),ColorGREEN;

DRAWTEXTREL(0,20,'所属板块:'+BKNAME),ColorRED;

DRAWTEXTREL(0,120,'每股收益:'+NUMTOSTRN(FINANCE2(3),3)+'元'+' 市盈率:'+NUMTOSTRN(DYNAINFO(39),2)+'元'+' 市净率:'+NUMTOSTRN((CLOSE / FINANCE2(4)),2)+'元'+' 净资产:'+NUMTOSTRN(FINANCE2(4),2)+'元'),Color00C0FF;

DRAWTEXTREL(0,270,'历史最高价:'+HHV(HIGH,0)),Colorred;

DRAWTEXTREL(160,270,'历史最低价:'+LLV(LOW,0)),ColorAFFF00;

销售毛利率:=FINANCE2(12);

主营收入同比:=FINANCE2(11);

净利润同比增长:=FINANCE2(10);

DRAWTEXTREL(0,170,'销售毛利率:'+NUMTOSTRN(销售毛利率,2)+'%'),LINETHICK1,COLORff00ff;

DRAWTEXTREL(180,170,'主营收入同比增长:'+NUMTOSTRN(主营收入同比,2)+'%'),LINETHICK1,ColorYELLOW;

DRAWTEXTREL(0,220,'净利润同比增长:'+NUMTOSTRN(净利润同比增长,2)+'%'),LINETHICK1,COLOR00FF00;

LJL07:=(3*C+L+O+H)/6;

金钱:(20*LJL07+19*REF(LJL07,1)+18*REF(LJL07,2)+17*REF(LJL07,3)+16*REF(LJL07,4)+15*REF(LJL07,5)+14*REF(LJL07,6)+13*REF(LJL07,7)+12*REF(LJL07,8)+11*REF(LJL07,9)+10*REF(LJL07,10)+9*REF(LJL07,11)+8*REF(LJL07,12)+7*REF(LJL07,13)+6*REF(LJL07,14)+5*REF(LJL07,15)+4*REF(LJL07,16)+3*REF(LJL07,17)+2*REF(LJL07,18)+REF(LJL07,20))/210,COLORgreen,LINETHICK4;

银线:EMA(CLOSE,6),COLORff00ff,LINETHICK4;  

该文观点仅代表作者本人,贝壳投研系信息发布平台

贝壳投研从多维度分析,整理了一份《成长50》的名单,可以关注同名公众号:"贝壳投研":Beiketouyan,进行领取(点击复制)

/阅读下一篇/

大智慧准确的逃顶抄底主图指标公式,大智慧点金高低指标公式

可能感兴趣的
热门推荐