大智慧就是不一样MACD指标公式,大智慧一个非常直观的成交量指标公式

股票公式 | 发布于2021-09-15

大智慧就是不一样MACD指标公式

SQX:=(C-MA(CLOSE,13))*100;

DIFF:EMA(MA(SQX,7),1),COLORWHITE;

DEA:EMA(DIFF,7),COLORYELLOW;

MACD:(DIFF-DEA)*2,COLORSTICK;

PARTLINE(CROSS(DIFF,DEA) AND DIFF<-0.1,15),COLORYELLOW,LINETHICK4,CROSSDOT;

低位金叉:IF(CROSS(DIFF,DEA) AND DIFF<-0.1,15,0),COLORYELLOW,LINETHICK0;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

PARTLINE(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,28),COLORFF00FF,LINETHICK4,CROSSDOT;

二次金叉:IF(CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1,28,0),COLORFF00FF,LINETHICK0;

A1:=BARSLAST(REF(CROSS(DIFF,DEA),1));

PARTLINE(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),40),COLORRED,LINETHICK4,CROSSDOT;

底背离:IF(REF(CLOSE,A1+1)>CLOSE AND DIFF>REF(DIFF,A1+1) AND CROSS(DIFF,DEA),40,0),COLORRED,LINETHICK0;

势: DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORGREEN;

{,COLORRED;

}A2:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF);

PARTLINE(REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),66),COLORF08000,LINETHICK4,CROSSDOT;

顶背离_:IF(REF(CLOSE,A2+1)<CLOSE AND REF(DIFF,A2+1)>DIFF AND CROSS(DEA,DIFF),66,0),COLORF08000,LINETHICK0;

压: DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORFFBB99;

A3:=CROSS(DIFF,DEA) AND DEA<0;

PARTLINE(FILTER(COUNT(A3,21)=2,10),53),COLORWHITE,LINETHICK4,CROSSDOT;

零下二次金叉_:IF(FILTER(COUNT(A3,21)=2,10),53,0),COLORWHITE,LINETHICK0;

DRAWICON(CROSS(DIFF,DEA) ,DIFF,7),ALIGN1;

DRAWICON(CROSS(DEA,DIFF) , DEA,8),ALIGN1;

金叉:if(CROSS(DIFF,DEA),diff,0),color00ff00,stick,linethick1;

{死叉:if(CROSS(DEA,DIFF),diff,0),colorff0099,stick,linethick1;

}选股:二次金叉>0 or 低位金叉>0 or 底背离>0;

0,colorgray;

DRAWICON(二次金叉>0 or 低位金叉>0 or 底背离>0,1,10);  

大智慧一个非常直观的成交量指标公式

虚拟量:=IF(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,MAX(VOL,DYNAINFO(17)*REF(MA(VOL,5),1)),0);

STICKLINE(DYNAINFO(7)=CLOSE AND DYNAINFO(10)=AMOUNT,VOL,MAX(VOL,DYNAINFO(17)*REF(MA(VOL,5),1)),7,-21),COLOR00C0C0,DOTLINE,LAYER7;

VAR1:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));

成交量:VOL,POINTDOT,COLORYELLOW;

买盘:IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLORRED,POINTDOT;

卖盘:IF(CLOSE>OPEN,VAR1*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR1*(HIGH-LOW),VOL/2)),COLOR00FF00,POINTDOT;

成交量比:买盘/VOL*100,COLORWHITE;

VAR22:=(CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100;

获利盘: WINNER(CLOSE)*100;

VAR33:=SMA(VAR22,3,1);

VAR44:=SMA(VAR33,9,1);

VAR55:=3*VAR33-2*VAR44;

VAR66:=VOL;

量比: DYNAINFO(17);

涨幅: (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;

角度: (CLOSE-REF(OPEN,29))/REF(OPEN,29)*100;

手: VOL/CAPITAL*100;

VAR77:=SUM(换手,30);

VAR88:=LLV(INDEXL,5);

VAR99:=HHV(INDEXH,5);

VARAA:=EMA((INDEXC-VAR88)/(VAR99-VAR88)*100,4);

VARBB:=MA(EMA(0.667*REF(VARAA,1)+0.333*VARAA,2),9);

VARCC:=MA(VARBB,30);

VARDD:=EMA(获利盘,4);

本盘亿股: CAPITAL/1000000;

VARF:=(涨幅>VARDD AND 角度<-30 AND 涨幅>3);

CROSS(VARBB,VARCC) AND VARCC<29;

CROSS(VARCC,VARBB) AND VARCC>58;

STICKLINE(VOL AND VAR33>VAR44,0,VOL,7,1),COLORRED;

STICKLINE(VOL AND VAR33<=VAR44,0,VOL,7,1),COLORCYAN;

STICKLINE(买盘>0,0,买盘,6,0),COLORRED;

STICKLINE(卖盘>0,0,卖盘,5.5,0),COLOR00FF00;  

该文观点仅代表作者本人,贝壳投研系信息发布平台

贝壳投研从多维度分析,整理了一份《成长50》的名单,可以关注同名公众号:"贝壳投研":Beiketouyan,进行领取(点击复制)

/阅读下一篇/

大智慧强势主升选股指标公式,大智慧暴雨密码主图指标公式

可能感兴趣的
热门推荐